Firefox and Internet Explorer Update

At this time, it is known that IE9 may not work correctly with Webmail Plus, and has a compatibility problem in GoWMU. Putting IE9 into compatibility mode resolves the GoWMU problem. Our software vendors are still recommending IE8.

Firefox 12 has been tested and is approved for use. Firefox 13 may also work. If you upgrade and run into problems, please let the Help Desk know. You may have to go back to FF12.

If you have any questions, please call the Help Desk at (269) 387-4357, option 1.